Jump to content
Sign in to follow this  

08 yzf 250 issues

Recommended Posts

Sup guys. Im working on my cousins 08 yzf 250. It only has about 10 hours on it. It has been sitting for a long time due to his dad woudlnt let him ride it. He is going to start riding it this summer but wanted me to due a service on it and find out why it wouldnt start. I tore the carb apart and of course it was full of old gas and tarnish. I cleaned it very good and made sure all jets were free flowing. After i got it put back together, it will start, but it backfires pretty bad. wont idle, and bogs when you hit the gas. Any ideas? Is there something else that im missing that needs cleaned due to old gas? Thanks in advance.

Share this post


Link to post
Share on other sites

yeah, the tank and all lines/fuel path out of it !

also , clean jets and everythign else in there ! check there isnt a birds nest in the air box ! lol....

Share this post


Link to post
Share on other sites

Haha. I drained and cleaned the tank and all lines already. I think i might not have cleaned the inerds of the carb good enough. Cuz it was pretty ugly.

Share this post


Link to post
Share on other sites

If it will not idle go back in and pull the jets out again, soak them in carb cleaner overnight. Sounds like the pilot and idle circuit are still clogged, I have seen some cases over the years where no amount of cleaning would work and buying new jets was the solution. Good luck and let us know how you make out.

Share this post


Link to post
Share on other sites

I didnt disassemble the slide. I will tho. I will also pull all the jets back out and let them soak overnight. They were in pretty bad shape but i thought i got them clean enough. Might need to go ahead and replace them. Idk. Thanks for the comments guys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...