Jump to content
Sign in to follow this  

Sounds like a rattle snake.

Recommended Posts

My bikes rattles like crazy!!

Replaced the cam chain yesterday, did the primary nut fix and the rattle sound is still there.

I know the bike i noisy.. But It wasn't this bad when i got it. In fact I don't remember any rattle when i got it.

I do oil and filter change every second month.

Is it supposed to sound like this? 👍

Edit:

Got the MCCT btw.

Share this post


Link to post
Share on other sites
My bikes rattles like crazy!!

Replaced the cam chain yesterday, did the primary nut fix and the rattle sound is still there.

I know the bike i noisy.. But It wasn't this bad when i got it. In fact I don't remember any rattle when i got it.

I do oil and filter change every second month.

Is it supposed to sound like this?🤣

Edit:

Got the MCCT btw.

How far from Steinar are you...... Perhaps he can help......Obviously something else is going on...... Just hard to tell without being there.....

👍:thumbsup:

Erling

Share this post


Link to post
Share on other sites

my 09 sm has a nasty rattle on the left side only when the bike is leaned to the right. everyone that has replied to my thread seems to think im paranoid and says its just a noisy motor but i know good and well it wasnt doing that when i got it in july. i have 2000 miles on it, did the fixes and still have the rattle that sounds like its coming from the starter area. who knows? cause noone seems to have had this problem. good luck getting it resolved.

Share this post


Link to post
Share on other sites

Update:

Rode the bike for about an hour.

After that...

I got 2 seconds with huge lack of power, then it stopped.

Pushed the bike all the way home..

When I got home It started up. Had It running idle then it suddenly died like before.

Guess It's the cam timings that's out of order?

Worst day ever!! This morning I couldn't get out of the house (lost my key) So i punched trough the window in the front door.. FML 👍

Share this post


Link to post
Share on other sites

ialdkaaco.jpg

This is @ TDC right?

ialdlaaco.jpg

My cam timings....

How did It run fine for an hour? 👍

Share this post


Link to post
Share on other sites
My bike has a funny rattle on decel that's been worrying me...

I get a quick rattle on decel that's very intermittent. Often it happens when I go from hard acceleration to closed throttle in a hurry, as happens when riding singletrack. Some suggested that it could be the slide in the FCR, though I'm notsure if you have the FCR.

Share this post


Link to post
Share on other sites
I get a quick rattle on decel that's very intermittent. Often it happens when I go from hard acceleration to closed throttle in a hurry, as happens when riding singletrack. Some suggested that it could be the slide in the FCR, though I'm notsure if you have the FCR.

I have an 03 E model so it has the FCR. It sounds like the cam chain noice that my KLR makes when it needs to be adjusted.

Share this post


Link to post
Share on other sites

You do not have it at TDC yet. There is the blue paint line and then right next to it is the actual timing line. Rotate a little farther and you will see the line with the T next to it. It looks as if you cam timing is correct once you move the mark to appropriate spot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...