Jump to content
Sign in to follow this  

rmz oil problems

Recommended Posts

hey i got a 05 rmz that has all the oil building up in the stator side. i had installed a new crank so i had the motor apart but now the oil wont flow back to the clutch side. it runs just fine but you dont know how much oil is in it. it doesnt leak a drop either. anyone know whats going on here? i called quite a few shops and they have no idea.

Share this post


Link to post
Share on other sites

Only the person who did the job will have an idea(not sure if you did motor), but hard to say from not seeing inside. Something IS wrong and may not last too much longer. I would definately look into it/strip motor again as its not normal.

Share this post


Link to post
Share on other sites

did u put the oil pump impeller back in correctly? Have to take off the inner right side cover but u can do this with the engine still in the frame.

Share this post


Link to post
Share on other sites

I wonder if a plugged transmission vent hose could cause enough of a vacuum the oil can't flow from one side to the other.....as in from one chamber to another. Probably not....just a thought.

Share this post


Link to post
Share on other sites

There is a reed one way check valve that is in between the two case halfs.

It's hard to do because of the shape but maybe that was put in backwards.

Look at a microfiche and you will see it.

Just a sugestion.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...