Jump to content
Sign in to follow this  

Water Pump Seal installed Backwards...

Recommended Posts

Though I understand that posting this will result in the scorn of the KTM community, I need some help. I bought a new water pump seal kit/assy from Travis @ Thumper Racing (I have an 01 520) along with the cam upgrades. Realizing the work was a bit too much for a newb like me, I enlisted the help (paid) of a mechanic friend. He did NOT watch the video Travis did and installed the seal backwards, meaning the two holes you nab with the snap ring pliers are facing inside the motor, not out. Needless to say it is weeping again.

Does anyone know if it possible to pull that seal out carefully and turn it around? I am hoping to not have to spend another 35 bucks for a whole new clip. 👍

Share this post


Link to post
Share on other sites

Problem #1 is I have no idea how your going to grip it to pull

Problem #2 is your going to damage the seals taking them over the snap ring groove in the cam. The little black sleeve Travis provides works good going on, may be worth trying coming off?

The retainer has 3 grooves;

outter groove has the smaller of the two Oring in it,

center groove is a channel for coolant to escape if there is leakage thru the seals,

inner groove is to accept the large Oring which is installed into the head first

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...