Jump to content
Sign in to follow this  

What else is there to do??????

Recommended Posts

I recently had my top end rebuilt. New piston new cam chain new valves. ONce i got the bike back it had all the powwer but was spitting oil out on the sides so i took it back they said pressure caused what the top of the casing to the cams kindof cracked they welded it back together and fixed the spitting problem. once ive gottent he bike back it has ran like crap. theres no torque at all in the low speeds of the gears. i belive a 65 has more power then the bike out of the corners and at take off. the bike just boggs when u crank on the throttle. i took the carb off found alittle water drainned it cleaned all the jets checked the timing everyhthing seems to be in place. now the bike is running at like 70% power. it still wont even lift the front wheel off the ground. im out of solutions im not taking it b ack to the shop i dished out 600$ and it seems to get worse every time they work on it. the bike doesnt really bog anymore it just doesnt sound the same and doesnt hav e near the power it should. does anybody have ne guesses at what to next try? we fooled witht he fuel screw and it doesnt really help.. after the cleaning of the carb the bike probably went from 50% to 70% but everyone says the bike sounds terrible it backfires and the exhaust turns bright orange within mins along with the cams getting extremly hot

Share this post


Link to post
Share on other sites

Your cam sprockets may have spun on the cams shaft.

Share this post


Link to post
Share on other sites
Your cam sprockets may have spun on the cams shaft.

Check that as well as the timing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...