Jump to content

Front brake sucks a**


Recommended Posts

When I got my bike the front brake worked excellent, and the pull was very firm the whole way, with no slack at all. As the pads wore down the brake started to not work as well, not very stiff, and quite a bit of slack. I just put new OEM pads on the front and it didn't seem to help at all. The brake pull completely in and bottoms out, and does so with not a ton of resistance. When I put the pads on I also bled the brake and made sure the oil level was full. The bike also has a Gold Fren aftermarket front brake line. Im thinking it has something to do with the piston or the caliper, or something.... any input is appreciated.

Link to comment
Share on other sites

keep bleeding them, I use a miti-vac brake pump and get gets all the bubbles out, you still most likely have a bubble caught somewhere, turn the bars all the way to left so the master is the highest point on the bike, let it sit for a while and then tap on the master with a screw driver until all bubbles are gone, letting this sit over night as well helps alot to.. if not then there can be an issue with the piston/caliper

Link to comment
Share on other sites

x2

Probably just air left in there somewhere. Flush a bunch of fluid through it too.

Replace the line with a stock OEM line if you think that might be the problem. After that I'd be looking at the lever or the caliper....

Link to comment
Share on other sites

buy speed bleeders and be done with it, forever. And get a set for every bike you own, I tossed my pump, one man bleeder and a large syringe in a box and forgot them. ebay all day long and cheap

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...