Jump to content

99 RM 125 keeps bogging.


Recommended Posts

Alright, the bike runs fantastic for the first 15 minute, then it will start having trouble reving up and lose it's throttle response. It is still ride able and doesn't prevent me from doing anything, its just annoying. Now this problem just recently started so I think it is one of these:

The fuel filter is clogged and needs to be replaced

or

the float height got all out of whack.

I do not think its the jetting because this problem just recently started.

I can't tell if it is running to lean or to rich, its almost like it fluctuates. So I thought it could also be related to the Dyna CDI, unlikely though. I'm just looking for some suggestions to what could be the problem. I run 100ll Avgas

Thanks

Tony

Link to comment
Share on other sites

So your telling us that it starts running like crap when it gets realy warmed up? Ok here is what you should do first. Getting to run like crap and then ride it for a little while and kill it, pull the plug and see what i looks like. White or gray we need to chase a fuel or air leak problem. Black and wet, you got a fuel or fire problem. When was the last time it had a fresh top end or re-ring? Air filter clean?

Link to comment
Share on other sites

Make sure the gas tank air vent is open, I had a similar problem on a bike and turns out the air vent hose was pinched so the tank wasn't getting enough air for the fuel to feed the carb. After the bike sat for a little it would run great again for 10 min.

Also clean the carb good, check your slow jet for cloggs. Good luck.

Link to comment
Share on other sites

Can someone tell what the floats should be set at on this bike? I too am having problems. Mine seemed way rich and no I have it too lean. Runs good for a short distance then stops. When you let off the gas the revs come back to a high idle before settling down.

Link to comment
Share on other sites

Can someone tell what the floats should be set at on this bike? I too am having problems. Mine seemed way rich and no I have it too lean. Runs good for a short distance then stops. When you let off the gas the revs come back to a high idle before settling down.

That sounds like a bad crank seal.

2nd Page, 1st post (post#10?) of the Suzuki FAQs sticky will have your settings.

Link to comment
Share on other sites

Ok I found some time to ride again and I think the problem is in the transmission. I only rode for 30 min. and then got a flat tire so im not entirely sure.

Whenever it bogs I shift up or down and it runs great again. I recently started using 10w-30 instead of the bell-ray mainly because it leaks oil and I change it frequently so its cheaper.- The oil leaks because the metal casing even, it needs to be brought to a machinist. So its not that im too lazy or stupid to fix an oil leak, I just that I dont have the time or the money.

Now when I fix the tire I will start using 30sae and see how it rides. Besides this problem, car motor oil makes it run alot better and shift smoother.

Also, it started become a pain in the ass to start when its hot. Idk if this problem is related not, my guess is the plug needs to be cleaned.

Link to comment
Share on other sites

Ok I found some time to ride again and I think the problem is in the transmission. I only rode for 30 min. and then got a flat tire so im not entirely sure.

Whenever it bogs I shift up or down and it runs great again. I recently started using 10w-30 instead of the bell-ray mainly because it leaks oil and I change it frequently so its cheaper.- The oil leaks because the metal casing even, it needs to be brought to a machinist. So its not that im too lazy or stupid to fix an oil leak, I just that I dont have the time or the money.

Now when I fix the tire I will start using 30sae and see how it rides. Besides this problem, car motor oil makes it run alot better and shift smoother.

Also, it started become a pain in the ass to start when its hot. Idk if this problem is related not, my guess is the plug needs to be cleaned.

Still sounds rich to me.

Its not your oil.

Link to comment
Share on other sites

It sure is amazing how fast a 125 will run when it is jetted right. Now I'm ready to get rid of it, lol. Really just need something a little tamer so I can ride with my boys. Looking at a klx300, also posted in the Kawasaki forum asking how they were. Figured mihylo might be able to help as well. Dear Suzuki god do you have any info on the klx?

Good luck with the smoker bro. Listen to mihylo and fix your jetting before wasting time on anything else.

Link to comment
Share on other sites

It sure is amazing how fast a 125 will run when it is jetted right. Now I'm ready to get rid of it, lol. Really just need something a little tamer so I can ride with my boys. Looking at a klx300, also posted in the Kawasaki forum asking how they were. Figured mihylo might be able to help as well. Dear Suzuki god do you have any info on the klx?

Good luck with the smoker bro. Listen to mihylo and fix your jetting before wasting time on anything else.

I heard the KLX were prone to overheating, but other than that they are all good bikes. If it were me I would look at one of the WR250's by Yammi. Thats a damn tough motor and I would go as far as comparing it to the XR motors of yesteryear.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...