Jump to content

Ssr 110 dx3


Recommended Posts

Just got my new dx-3 in the mail thanks to Tbolt. So far she runs great besides the chain stretching but just one question if anyone has a SSR is it normal to smoke a lil bit after it warms up or is it just during the break in period that it does this?

Link to comment
Share on other sites

How much assembly is required when it shows up? Does it have enough power? How does the suspension work/feel on it? How much do you weigh? Sorry for the 20 questions but I'm contemplating buying one of these but I'm slightly hesitant.

Link to comment
Share on other sites

How much assembly is required when it shows up? Does it have enough power? How does the suspension work/feel on it? How much do you weigh? Sorry for the 20 questions but I'm contemplating buying one of these but I'm slightly hesitant.

Assembly was easy took maybe 5 mins to mount the front tire and bars. And yes the power is great it pulls on my buddies crf50 with an 88cc big bore kit. And for the suspension the rear shock is a bit stiff and the forks are too soft so i plan on upgrading both and i weigh around 155. but for the price its a great bike

Link to comment
Share on other sites

I just got one from tbolt as well and noticed it smoked a little bit during intial set up. But I have probably 6 hours on it now, and its not smoking anymore. Noting too serious I dont think, just the motor breaking in, plus I got some wd40 on the motor so that could be part of it too, esp. if you lubed everything. Oh and for the shocks, for now at least just take them apart and add some fork oil, really simple to do. SGR has a great tutorial, follow these directions, and you wont have a problem.

http://www.sgr-usa.com/pages.php?page=tech%20info

I didnt have 20w, all I had was 10 so I put 1/2 cup in 8oz, (there was around 1/4 of a cup in there to begin with) and they are much better but still soft, I am going to up it to 3/4 of a cup and see how it works out. Plus the oil thats in them isnt very good to begin with.

I dont know if you changed the oil or not (your post on setup doesnt say), but you probably should. The stuff that comes in there is TOTAL JUNK. Mine was multicolored, looked terrible.

Link to comment
Share on other sites

I just got one from tbolt as well and noticed it smoked a little bit during intial set up. But I have probably 6 hours on it now, and its not smoking anymore. Noting too serious I dont think, just the motor breaking in, plus I got some wd40 on the motor so that could be part of it too, esp. if you lubed everything. Oh and for the shocks, for now at least just take them apart and add some fork oil, really simple to do. SGR has a great tutorial, follow these directions, and you wont have a problem.

http://www.sgr-usa.com/pages.php?page=tech%20info

I didnt have 20w, all I had was 10 so I put 1/2 cup in 8oz, (there was around 1/4 of a cup in there to begin with) and they are much better but still soft, I am going to up it to 3/4 of a cup and see how it works out. Plus the oil thats in them isnt very good to begin with.

I dont know if you changed the oil or not (your post on setup doesnt say), but you probably should. The stuff that comes in there is TOTAL JUNK. Mine was multicolored, looked terrible.

Thanks man for the info im going to try that out tomorrow but yea first thing i did once it was assembled was change the oil.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...