Jump to content

Throttle play & abnormal revs ?!


Recommended Posts

Hi,

I have a question that i don't think is bike specific. I have a CRF150F 06' Australian make i have pulled apart and cleaned the carburetor as it was not starting properly. All is fine and the bike starts but it has lots of play in the throttle now starts on full throttle and revs the shit out of its self.

I have taken the carby apart again with the throttle cable still attached and the large amount of play in the throttle is due to the cable extending further then the slide if this makes sense? there is a small amount of spring back in the cable and i have made sure the slide is in its position correctly

Im not sure how to fix this play to make the bike rev normally

any help would be appreciated.

Gabbee

Link to comment
Share on other sites

there should be an adjustment coming right out of the throttle tube. don't be afraid to lube the cable also, it might just be binding up inside the cable housing. a check you could perform without the motor running is to open the throttle up all the way, you should hear it hit the stop inside the carb. then shut the throttle all the way, you should hear it hit the idle adjusting screw.

Link to comment
Share on other sites

don't want to high jack your post but I am having the same type of problem after purchasing a new carb kit. The carb works fine when it is off, I can tell the slide is hitting on the top and bottom.. yet when i start the bike, if you hit the cable or pull on it the bike revs like crazy. just touching the cable makes the bike rev, afraid to let my son ride it in fear he will brush up against something on a trail and send the bike into a speed race over a cliff. any help would be greatly appriciated. thanks!

larry

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...