Jump to content

Engine missing at speed and under load. Advice please!


Recommended Posts

Interesting thing happening to the Z. Hopped on it in the morning to go to work and no blinkers. I did not think much of it till the ride home. The bike started missing at speed. I got off the gas and back on and it went away. Further down the road and closer to home it happened again several times.

Back to the blinkers. I wired L.E.D.'s to the bike using the flasher relay method. It has worked flawlessly, until now. I looked to see if the relay was broken or the wires disconnected. I checked to see if it was broken because I was riding dirt the other day and went over the bars and the front saw minor damage. The relay was cracked and the wires were disconnected.

My question to the experts is; Can the two wires (orange and blue on the flasher circuit) touching cause a short in the system to create a problem with the ignition system?

Please advise!

Link to comment
Share on other sites

Thanks! ­čśĆ

Now go do those battery tests.!

Just performed all of the battery,rr, and stator tests. Everything is within the limits stated in the FAQ's area: https://thumpertalk.com/forum/showthread.php?t=627031

I fixed my blinker problem. The tumble took it's toll. The flasher relay was cracked and the blue and orange wires were touching each other.

This bike is 2 years old with 37,000 miles on her. I think if the problem persists, I will be looking at replacing the battery.

Thank you for your expert help Eddie and William. It is much appreciated. I would not know where to start if it wasn't for the both of you and TT.

Time to put her through her paces and see what happens.

Link to comment
Share on other sites

Everything is working good for the most part. I put an additive in the fuel to break up and debond any carbon in the intake and combustion areas. The bike hicupped a few times today but nothing like it did Friday. I was told to run a few tanks of this treatment and let it work on the carbon deposits. It seems to be working on the first tank I ran through it. The next tank will happen later this week.

Is it possible that a valve was being held up by carbon deposits?

Link to comment
Share on other sites

Well, I stopped to fuel up, shut off the engine and when I was done tried to start and nogo. She did not start. I was close to home so I pushed it the rest of the way.

I pulled the plug and checked to see if it had spark and nothing. I had the old plug so I checked it and no spark with that one either. I will list all of the ohm and volt readings in a bit. I did all of the checks again and got the readings I got the first time. This leads me to believe I have done something wrong.

The only tests I did not do was the peak output tests. This will be done today. I will post the findings of them also.

If anyone has any input it will be appreciated. Thanks in advance.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

├Ś
├Ś
  • Create New...