Jump to content

Idle problem and top end power problem...


Recommended Posts

I have a 1991 KTM 300 2 stroke I just picked up. It wasn't running. I removed the carb and cleaned throughout. I changed the plug and it fired right up but wouldn't idle. I tried turning the idle/choke knob on the carb and it didn't seem to affect the engine. That's one part to the problem.. Next, I took it for a little ride down the street and as soon as the rpms hit around the mid range, the engine just falls on its face, but the lower end runs great with lots of power. Any ideas?????????????

Link to comment
Share on other sites

I have a 1991 KTM 300 2 stroke I just picked up. It wasn't running. I removed the carb and cleaned throughout. I changed the plug and it fired right up but wouldn't idle. I tried turning the idle/choke knob on the carb and it didn't seem to affect the engine. That's one part to the problem.. Next, I took it for a little ride down the street and as soon as the rpms hit around the mid range, the engine just falls on its face, but the lower end runs great with lots of power. Any ideas?????????????

PV stuck, need cleaning.? Probably need to go thru the carb again. make sure all the smallest orifices are clean, including the choke circuit. If it won't idle, the pilot is likely still clogged. Might be simpler to get a new one. they are cheap.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...