Jump to content

Black smoke coming out of muffler


Recommended Posts

So I rebuilt my 07 KX250F when i started to make some black smoke out of the muffler. So I threw in a piston, rings, blah blah blah. Needless to say, I changed everything I should have. But now after the rebuild probably about 10 hours after, it still makes black smoke, sometimes it gets real heavy in the exhaust end cap and fender and sometimes not. I think it gets worse when I lug it. I try not to anyway...What is this? I got a two bros muffler, new intake valves, valve seals, rings, a slightly scored piston from a rolled ring very small area about 4mm around the piston pin (long story short, first time I put it together I swapped the shims thinking I was putting them in spec, out of spec hit piston till it broke valve and guide, fixed and repaired now though), JD jetting, thats it for engine mods really. What is causing this?

Link to comment
Share on other sites

all very valid. Well it should be jetted properly, 42 pilot, 182 main, I clean the air filter ever couple rides. It probably could be done now as it sits... and I just took the carb apart when I did the top end, and lubed up the hotstart, lite grease on o ring and cleaned out the hole. Everything seems right to me. Maybe I should rejet again...it is almost 110 out. and a 182 might need to be a 180. IDK. ill try everyhting you mentioned to make sure, but my hotstart has never froze up and my jetting never pops and the thing runs well. Ya know what it might be that fat ass o ring I put on the accelerator pump, might dump too much fuel and it slowly causes the black smoke. Im about ready to go back to everything that used to work. I bet its that damn oring... I have a smaller one I can try that came with my JD kit.

Link to comment
Share on other sites

what altitude do you run at? I run at approx 2-3000 on a regular basis. In the winter I can run a 185 to a 188. In the summer I run about 180-182. It runs so well, I dont have a problem with bogging and it seems to do well in the power department. I think the oring and a good FS adjustment will fix most the problem.

Link to comment
Share on other sites

I will definitely check that out. Its just so wierd, because out here in the winter when it gets cold, the air gets extremely dense, more so than other places, and vica versa for summer, so I moght bring a 180 and 178 with me to the track. Im pro at changing jets. :banana: never killed anyone to try I guess. I can run as high as 188 in the winter. It never made black smoke before and now all of a sudden it starts making it. Not that it happened over night, but it just ever so slowly startting making smoke on the fender. Ill try anything right now...

Link to comment
Share on other sites

black smoke = fuel

tiime to lean out your setting. I don't know about where you are at but for me home is at 700 ft, where we ride is 4000 to 7500 ft. We have to jet on the lean side so that when we get to the riding areas the mixture is as it should be.

Link to comment
Share on other sites

I amdetermined at this point to make this work. I wonder if I need to drop the clip one? that could be a problem I think it might be in the 5 position from top, maybe I should try 4th or maybe even 3rd. I still going to try a 180 and 178 and if the 178 is a tad lean, ill pu the 180 an ddrop the needle one! sounds like a plan to me. :banana:

Link to comment
Share on other sites

so here the consesnsus as of now. ill have pics too. Very dirty air filter, I havent rode the bike very much lately so I will clean the filter up and put my other one on, this is what having 7 bikes does to you! and a 185 main, i used to run that in the winter! so I went to a 182 and reset FS at 1.25 turns out. I will bring a 180 and 178 next time I ride it to check which one is closest to alt/temp im at this time of year. Meanwhile your pondering my hopes and prayers here are some pics.

DSC04030.jpg

DSC04029.jpg

DSC04028.jpg

DSC04026.jpg

Link to comment
Share on other sites

that air box is nasty!!! never ride the bike after you wash it without changing the filter. the fender doesnt look to bad. with a 42 pilot you need to be at least 2 turns on the air screw. how old are the rings maybe some blow by? but i still think you are way to rich. i would also bring a 175

Link to comment
Share on other sites

that air box is nasty!!! never ride the bike after you wash it without changing the filter. the fender doesnt look to bad. with a 42 pilot you need to be at least 2 turns on the air screw. how old are the rings maybe some blow by? but i still think you are way to rich. i would also bring a 175

well I just did a topend like 5 hours ago. I probably wiped the fender off. Thats just what the air box looks like, its a nasty desert out here and I dont have time to wash out all of our bikes airbox. I just make sure to be careful when I put the air filter in. I have a little medicine bottle I keep all my mains in, from 190 to like 150, so ill just take that to the track. whoo! what a fun job, Ive never worked so hard on this bikes jetting before. looks like I needed a new lesson on how to jet it. I guess. Well I got a new filter and a 182. Also when I had the bike apart for topend, I used a choke cleaning bristlebrush for shotguns on a cordless drill, to clean out all the black junk in the header. SOOOO MUCH CAME OUT! I guess I have a jetting problem. lol, to say the least. Ill keep you folks updated. Im going to do a trail ride up in Pioche this weekend, Ill take that bike since I changed a bunch of stuff, maybe my KDX as well. IDK if ill get to take my KXD project bike, the stupid intake boot cracked where it ahd dry rotted and UUUHHHH!!!! I just want to ride!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Link to comment
Share on other sites

  • 2 weeks later...

ok guys here is the verdict. rode the bike finally, last tuesday. new filter 182 main, 1.5 turns out on the FS. It was popping just a little, but I didnt get to adjusst it, because once again bike started making a wierd zinginginging sound. I have a vid but it wont upload. anyway it ran great with the new link and I was having a 1.5 lap ball! some guy told me the chain guide on the head cover can come loose and cause the noise. The bike kept running tho, just idling not riding. it idled for a second until I could shut it off. soooo Im going to take that apart at some point, after I come back for thanksgiving break and get that fixed. the old KDX proved to just be reliable like a 2 stroke!!! I put on different larger forks from other different larger forks for rubber mounting, thats another story...So thats my deal I fix this dumb zinging sound and I should be good, hopefully. just updating you guys on my bike it went well and I dont reckon any black smoke. thank god. I can handle a little bit, that just meanss more power.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...