Jump to content

EMGO mini blinkers not blinking XR650L


Recommended Posts

I have been replacing the stock blinkers with "MINI W/LITE CATEYE BLK/CLR LENS" blinkers. I replaced the rear blinkers first, they have been working great. After a week of trouble free blinking, I got sick of looking at the big stockers in the front, so decided to replace them today.

When I install a blinker on the front and turn it on, I only get a solid light, no blinking.

Switch back to stock (front only, still has the new mini's on the rear) and it blinks. I even hooked up the stock front blinker on one side with the new mini on the same side, giving me three blinkers on one side, and they all blink (just at a faster pace than normal). I then hooked up two new mini's on the front same side, and three blinkers work on the same side (faster pace).

I'm wondering if these mini lights don't draw enough power to activate the blinker. :banana:

These are normal bulbed lights, not LED. I tried the search function here and was unable to find a simular problem. Any thoughts or experience would be greatly appreciated.

Thanks

Tom

Link to comment
Share on other sites

Sounds like the bulb wattage are less then the stock bulbs and doesn't cause enough resistance for the flasher to work properly,so either the different flasher or find some higher wattage bulbs that will fit in the new blinkers or add resisters.

Link to comment
Share on other sites

Another easy fix to a head scratchin issue thanks to you good people on Thumper Talk.

Went to NAPA auto parts and got a NAPA brand 552 flasher for under $3. Works great.

Thanks everybody!

Tom

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...