Jump to content

Neutral Limit Switch


Recommended Posts

I have an 08 TE450 that is not starting due to the neutral limit switch. A couple of weeks ago I could wait about 10 - 15 seconds and the neutral idiot light would light and the bike would start fine.

The light is not coming on at all now. Where is it located and can it be adjusted? Could I have hit some brush that misaligned the switch?

Thanks for you reply

Bruce

Link to comment
Share on other sites

Hi Bruce,

I believe it's an elecrical unit bolted just above the gear selector shaft,

I haven't owned a 450,

but my 410 was of a similar layout.

try having a look on the exploded views ( halls / czech site).

if it's been getting gradually worse then I'd assume an electrical issue , or it's actually worked loose,

knocking it out of position would have been a sudden change?

Hopefully somebody else has had the same issue,

I think that set-up has been in use from 2003.

good luck,

Charlie

Link to comment
Share on other sites

Thank you Charlie. It did gradually become worse. For some time it was almost like a heating element that would make contact in 10-20 seconds.

Can you tell me where I will find the Halls/Chech site?

try having a look on the exploded views ( halls / czech site).

And thank again

Bruce

Link to comment
Share on other sites

It appears the GPS (gear position sensor) in the service manual or idle transponder assembly in parts manual is out of specifications on my 08 TE450. My dealer and the Husky warehouse does not have the sensor.

Can anyone tell me if this sensor can be bypassed?

Thanks for any information.

Bruce

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...