Jump to content

09 RMZ450 probs


Recommended Posts

hey guys..im having issues with my 450 sputtering pretty bad at like quarter throttle..wide open it runs great but and when i'm rolling the throttle on coming out of a turn it bogs pretty bad and when i take it down the road and hold it at quarter throttle it cuts out..i've cleaned the throttle body and even have checked my fuel filter in the tank..just wondering if anyone else has had these similar issues and knew of any solutions

Link to comment
Share on other sites

Hello my friend, just for you gyes to know!

That same problem I start having with mine few weeks ago, I did check my air filter, took the power commander off, check all the plugs, clean and lubricate the plugs and the problem still. I was wondering if the injector could be a little dirty but me and my friend open the valve cover and check the valves and they were slightly loose, so we are going to put some other shims, they ussually get loose for the hours that we spend running. I'll let you know tomorrow because today we are going to work with that. But thats probably tha case, we allready had this problem before with some ATV's, like the Suzuki LTR 450, the Honda TRX 450 and the Yamaha Raptor 700. Hope we could solve this one too, but I'll let you know!

Link to comment
Share on other sites

I had a similar issue on my 08 450, about quarter throttle it would miss like it was hitting the rev limiter, I checked everything I was able to so I took it back to the dealer I purchased it from, they found a tps sensor that needed to be adjusted and this was with only 4 hrs on it, its been awsome ever since and its pushing a hundred hrs now. Your issue may be the TPS sensor I have heard, at least in my area, of some TPS problems in the suzis.

Link to comment
Share on other sites

Hello again!

Well maybe this could be your case! We just replace the valve shims and that corrects part of the issue. They messure like 6 and it's supose to be between 10-12!

It just starts really quick but there still some bogging problems.

Can someone tell me how we can messure the TPS? I mean how many ohm should have? Thanks!

Mfranzdorf here is a explanation:

When you use a titanium valve with some different materials as the shims are, they get wear down. So there was a small room between them, so you can hardlly notice you need to messure it. I really didn't bellive it till we open the valve cover and check it I don't think it haves the 40hr's (pretty sure is not), I do take good care in my engine I use Motul 300 and change it evry 3 rides, I'm not a pro rider but I push my limits on it, so they can get damage too. And I don't think that can happen to a new engine.

Maybe this could help someone else issue!

Edited by 12rafel
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...