Thoughs on stators--Experience with RMStator.com?

Virgin post... Out looking for stator information! I've gone through 3 stators now (my o.e. and 2 from ricky stator? I'm wondering if the quality of the ricky stators are just very low and are failing within 3-4 rides they all failed under normal conditions sure sucks having a bike that is far from reliable and getting to be really expensive. Not to highjack but has anyone else run into this problem 98 rm125 or what would possible cause multiple stator failures? I'm going to keep hunting around hopefully I can come up with some info before throwing away another $100 !

Virgin post... Out looking for stator information! I've gone through 3 stators now (my o.e. and 2 from ricky stator? I'm wondering if the quality of the ricky stators are just very low and are failing within 3-4 rides they all failed under normal conditions sure sucks having a bike that is far from reliable and getting to be really expensive. Not to highjack but has anyone else run into this problem 98 rm125 or what would possible cause multiple stator failures? I'm going to keep hunting around hopefully I can come up with some info before throwing away another $100 !
i'd be checking ground connections, making sure they were tight and clean, if the current can't travel easily it'll back up in the coils and overheat them.......sorry rotbox, no experience using rmstator, is oem alot more?

Thanks for the info I've chased every single wire on that bike and cleaned every ground along with dilectic grease being used on all connections, is it possible for the coil to cause the burn't out stator? the only thing have not replaced are the coil and the ecu. thanks alot for the help i'm in the process of re-winding my own ignition coil on the two spare stators i'll be crossing my fingers. . gotta love electrical!

Thanks for the info I've chased every single wire on that bike and cleaned every ground along with dilectic grease being used on all connections, is it possible for the coil to cause the burn't out stator? the only thing have not replaced are the coil and the ecu. thanks alot for the help i'm in the process of re-winding my own ignition coil on the two spare stators i'll be crossing my fingers. . gotta love electrical!
i imagine if the coil had too high of a resistance on the primary side it could. or maybe you just had some bad stators, 3 in a row seems not likely though.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now