Jump to content
Sign in to follow this  

Help needed bikes running odd.

Recommended Posts

I have a 2006 crf just had new valves piston gas flowed head and stage 1 hot cam but its not running right, when i off the gas it pops and bangs till you get back on the gas and it dont feel to have the power it should. i dont know what jets the bike has.

Share this post


Link to post
Share on other sites
I have a 2006 crf just had new valves piston gas flowed head and stage 1 hot cam but its not running right, when i off the gas it pops and bangs till you get back on the gas and it dont feel to have the power it should. i dont know what jets the bike has.

Definitely very lean!!

If you have had the head and cams done, you will most definitely need to re-jet the bike to get more fuel in, to balance out the amount of extra air that you have now got moving thru.

Do a search in this forum - I'll be willing to bet your jetting solution is posted on a thread here!!

Share this post


Link to post
Share on other sites

Porting and cams require a leaner mix, not richer.

Decel pops are caused by:

Exhaust leaks/no packing

Hot start stuck open

Clogged pilot jet

Keep in mind too, you are running a race engine for an MX bike, not a trail bike. Race bikes do not coast. They are all WOT then 100% brakes. If you are coasting, then you are not a winning racer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×