Jump to content
Sign in to follow this  

350sxf wont start

Recommended Posts

well my 350 seems to be pretty dead at the moment,last time out i noticed a little bit of oil puffing from the breather but the bike was running good and hasnt used any oil,it then became hard to start and had to bump it couple times but now its real dead,turns over ok but splutters and backfires on choke.had the fi apart but thats all clear,any ideas

Share this post


Link to post
Share on other sites

How many hours is on this bike?

Mine was hard to start until it had some hours on it and even now I have to use a certain technique when it doesnt fire up instantly.

Jason

Share this post


Link to post
Share on other sites

Check all the wiring for the FI. Check even the wiring INSIDE the tank. I´ve seen wires become loose in there. Also - check that none of the gas lines aren´t clogged-not even partially. Be careful when disconnecting the fuel line so you don´t get any debris in there in the process. Those passages are TINY. Check the main power relay box so it hasn´t rubbed against the sub frame rail. God bless the FI system ! An MX bike MUST have one to be adequate...:thumbsup:

Also - check all the wiring for the e-start if it doesn´t turn over properly. Crease all the connections with die-electric grease while at it.

Share this post


Link to post
Share on other sites

its dne about 20 hrs now and been fine,i originally fort the tps was faulty because the fi flashed up 6 short flashes but ive changed that ,sum people are saying you need ktm dealer to reset it but ive swapped mine around a few times with my husaberg and neither have needed reseting.ive not checked the tank but pump seems fine and also gave the fuel lines good clear out,it kinda fires up and backfires ,also the exhaust gets warm so its nearly goin i guess

Share this post


Link to post
Share on other sites

at first once the battery had died we bumped it twice no problem but after stopping for 20 minutes we tried again and nothing,seems to be nearly firing coz the exhaust is getting warm

Share this post


Link to post
Share on other sites

ok well bike has been at local ktm dealer for 4 days,they cudnt find no faults,so got it back home and thought id try and bump it and yea it fired up!!ran it about turned choke of and it killed it in an instant,wont run with out the choke or start on the button,anyideas again?

Share this post


Link to post
Share on other sites

ok, first off the sfx 350 takes about a tank of fuel before it will idel high enough that you can use the idel at all, secondly its not a choke for say its more of a high idel control, thirdly the motor is real tight and the battery needs to be charged completely to turn the motor over enough to fire....get it started and ride it for an hour. Turn the idel all the way up, you will notice that it will start needing to be turned down as the moter breaks in.

Share this post


Link to post
Share on other sites

So the dealer gave it back to you not going?

Has the compresion been checked (Leakdown will be most informative method), as that can effect the starting.

Share this post


Link to post
Share on other sites
ok well bike has been at local ktm dealer for 4 days,they cudnt find no faults,so got it back home and thought id try and bump it and yea it fired up!!ran it about turned choke of and it killed it in an instant,wont run with out the choke or start on the button,anyideas again?

There has been several cases of glogged injector passages. Those are t i n y ... 2012 FI bikes come with an little filter you place inside the fuel hose just where it enters the injector. Can be retrofitted to 2011 bikes as well. IMO KTM should send those filters out to everyone who´s bought the 2011 FI bike too. Without any cost.

Once more - God bless the Fuel Injection. What would the worldwide MX community do without it... Except maybe ride around their outdated carb-bikes or something instead than being lost in the dark corners of the carage trying to figure out the damned FI system. :smirk:

Share this post


Link to post
Share on other sites
So the dealer gave it back to you not going?

Has the compresion been checked (Leakdown will be most informative method), as that can effect the starting.

Yea ive taken it away from them because they were unable to find the fault,so husaberg dealer has It now

Share this post


Link to post
Share on other sites

Well i have the bike back now all fixed,at first they found the injector was wasnt working properly so replaced that but it still wudnt start,so ended up looking at the piston and it turns out the ring was upside down??!!.i had bought the bike with 15hours on it so looks like its had a new piston.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×