Jump to content
Sign in to follow this  

Indicators flash randomly on my XR600R

Recommended Posts

I have a 1994 XR600R,

I went out for a ride yesterday with my friend. He pointed out that there was something wrong with my indicators. I looked at them more closely myself today. It seems as though they flash t random in an almost morse code type of way. When i indicate any way they'll come on and maybe flash normally twice, then they wont flash, they'll then stay on for one or two seconds, and just continue flashing randomly. Not necessarily in that order.

Just wondering if anyone knows how to fix this?

Share this post


Link to post
Share on other sites

if they come on randomly when turned off, this tells me that there is a short in the switch that channels the flash. if they go randomly when turned on, or like you say, morse code like, this also tells me that they are on, but are getting more than one signal to flash, so the more i think about it, replace the flasher first (cheap, like $5 at any auto store) or maybe do some wire ohming first. then flasher, then switch.

Share this post


Link to post
Share on other sites

Mine has no battery and they flash rapidly at idle but normal when the RPM's are up. The setup has two flashers (one for each side) possibly for the low voltage.

Share this post


Link to post
Share on other sites
Mine has no battery and they flash rapidly at idle but normal when the RPM's are up. The setup has two flashers (one for each side) possibly for the low voltage.

is the flasher in the circuit before or after the switch?

Share this post


Link to post
Share on other sites
if they come on randomly when turned off, this tells me that there is a short in the switch that channels the flash. if they go randomly when turned on, or like you say, morse code like, this also tells me that they are on, but are getting more than one signal to flash, so the more i think about it, replace the flasher first (cheap, like $5 at any auto store) or maybe do some wire ohming first. then flasher, then switch.

Cheers mitchn06,

I went down to the local auto store and purchased a new turn signal relay. It worked a treat.

Share this post


Link to post
Share on other sites
is the flasher in the circuit before or after the switch?

They are after the switch.

Glad to hear your problem solved RossN.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×