Jump to content
Sign in to follow this  

Vent kit + Block off kit install issue

Recommended Posts

Hey all,

Sure hope this isn't a repeat but I've been searching for my specific issue and can't find it.

So, My 2008 CRF450X just came out of the shop not long ago, and was supposedly "jetted" correctly. I installed the jet and needle for my correct elevation, and correct needle position, the dealer went over it and checked it out as well to make sure I did the right thing. I've since taken it for a ride and things are fine, lots of power, and no issues! Life is good!

So tonight I decided to install the Applied Racing Vent kit, and AIS block off kit. While the installation went fine with 0 issues. I tried starting the bike and got it to idle for about 20 seconds and that's it. During that time I noticed that it was not a smooth idle, and using the choke (on a cold engine) made the bike die more and the idle to become worse.

So i've tried to make it work by messing with my fuel screw. I screwed it all the way in, and started from 2 turns out, trying to start the bike every half a turn passed 2, until around 3 1/2 to 4 turns out I finally got it started, but it was rough, and died again after like 10 seconds.

Any ideas? Typically what would need to be done after installing those kits? make the bike more rich? or lean? and is 4 turns out way too much? Do I need a new fuel screw?

Here is the current setup;

2008 CRF450X

FMF MegaBomb S/S Header

FMF Q4 Exhaust

Dynojet jet kit (136 main jet, Needle 3rd from the top) <- as per instructions

Applied race AIS block off kit

Applied race Vent kit

Thanks for help in advance!

Share this post


Link to post
Share on other sites
Hey all,

Sure hope this isn't a repeat but I've been searching for my specific issue and can't find it.

So, My 2008 CRF450X just came out of the shop not long ago, and was supposedly "jetted" correctly. I installed the jet and needle for my correct elevation, and correct needle position, the dealer went over it and checked it out as well to make sure I did the right thing. I've since taken it for a ride and things are fine, lots of power, and no issues! Life is good!

So tonight I decided to install the Applied Racing Vent kit, and AIS block off kit. While the installation went fine with 0 issues. I tried starting the bike and got it to idle for about 20 seconds and that's it. During that time I noticed that it was not a smooth idle, and using the choke (on a cold engine) made the bike die more and the idle to become worse.

So i've tried to make it work by messing with my fuel screw. I screwed it all the way in, and started from 2 turns out, trying to start the bike every half a turn passed 2, until around 3 1/2 to 4 turns out I finally got it started, but it was rough, and died again after like 10 seconds.

Any ideas? Typically what would need to be done after installing those kits? make the bike more rich? or lean? and is 4 turns out way too much? Do I need a new fuel screw?

Here is the current setup;

2008 CRF450X

FMF MegaBomb S/S Header

FMF Q4 Exhaust

Dynojet jet kit (136 main jet, Needle 3rd from the top) <- as per instructions

Applied race AIS block off kit

Applied race Vent kit

Thanks for help in advance!

I don't know what Kehien jet the Dynojet main 136 would be, but it should be 160-170.

You have plugged a vent somehow.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×