yz 250 handling issue

I picked up a 02 yz 250 a couple days ago. I took it out for the first time yesterday to a local track and this thing handles terrible. The rear wheel has tons of wheelsping which I understand is normal on a 250. My real issue however is the front end. It feels like I'm riding on ice. The front tire won't stay in rut and it wants to wash out fronm under me with the slightest amount of turning and brake application. To give you some background, I've been riding and racing for about 3 and a half years. I currently own a yz 125 and I used to own a crf 450 until the rod decided to exit the engine via the front of the cases. On my 125 I have jm racing suspension that works like a dream. I figured I was going to hop on the 250 and it would feel just like the 125 because of similar geometry. Boy was I wrong. I. I don't want to cough up the money to get the suspension done on the 250 if its not going to fix my issue. Any ideas on where to start? I thought about slapping my 125 suspension on it and see what happens.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Rixter
      A tiny clear rubber tube on bottom of carb.  On bottom sort of on side, by floats, the other end just hanging down.  Was it always like this? Or does the other end go somewhere?  Today after multiple trys with kick, choke on/off ,,,fuel keeps pouring out the tube.  This bike has always been hard to start.   Thanx  guys!
    • By Brock granberg
      I just did my valve adjustments and put my YZ250f back together as far as the valves, shims buckets and cam covers on but I need adhesive for the plastic valve/cam cover and I am stumped as far as what to use and where to get it or even what to call it! Need to get some soon im in need of a ride!
    • By ThatE30GUY
      Hey guys, I bought this YZ85 and came to realise the clutch wasnt working, so I drained the oil (Jet black) and pulled the plates out and cleaned them. I assumed finding a torque wrench would be easier than it has been. Does anyone know how to torque the clutch springs to spec without a wrench? Any insight helps.