Jump to content
Sign in to follow this  

04 KTM Senior Adventure wont keep running?

Recommended Posts

My neighboor has had this bike sitting in his garage for like 5 years.... My daughter has been riding a TTr90 for a while and was beggin me to ask them if she could try that little bike out. Same seat height, but as you know, a LOT lighter and a lot more power...

Anyhow, it was the guys grandkids and he quit riding and they never sold it. Anyhow, I took it to my garage, emptied the tank (looked like orange juice coming out of it)... pulled the carb and took it all apart, pulling out all needles and jets, scrubbed it with carb cleaner and compressed air...everything looked good to go.

Put some gas in, choked her and she fired right up. I could rev her up pretty good for about 3-5 seconds, then she dies. Then to start her I have to hold her wide open and kicks 5-10 times and she fires and runs for 3-5 seconds and dies...

Ideas? I sure appreciate any advice. When it does run (3-5 secs) she seems to run REAL well....??????

Share this post


Link to post
Share on other sites

You did put in a new airfilter as well right? I know if it has been sitting that long, the filter is toast. Also how well did you clean the fuel tank? Sounds like a carb issue to me. Getting gas then something plugging the jet starving it of fuel. I know you took it apart and cleaned it, but with fuel that old and it sitting so long, who knows what was in the fuel lines. New tranny fluid might help out as well with the clutch.

Share this post


Link to post
Share on other sites
You did put in a new airfilter as well right? I know if it has been sitting that long, the filter is toast. Also how well did you clean the fuel tank? Sounds like a carb issue to me. Getting gas then something plugging the jet starving it of fuel. I know you took it apart and cleaned it, but with fuel that old and it sitting so long, who knows what was in the fuel lines. New tranny fluid might help out as well with the clutch.

X2 on the carb issue. Might want to do a compression test on it also. Anything less than 120 psi needs a new top end

Share this post


Link to post
Share on other sites

I didn't replace the air filter yet, I actually took it out to make sure it wasn't air starved and so I could spray a little carb cleaner in it when it fired to see if it would keep it running. Didn't work though. I'll get a new filter.

I'll replace tranny fluid too...

I also suspected a jet is getting plugged... I'll clean them all again then flush the dog poop out of the tank and the fuel line, but if I pull the fuel line now and turn the gas on, it sure seems like its running nice and clear...

As for the top end.... supposedly when the kid quit riding it, it was running great and he was competitive with it. Bottom line right now is that I just want to get the dang thing running so my daughter can give it a whirl to see if it works for her. The height is just right, but she is 10 and weighs about 65#... so I know its getting close to being too small for her. Ultimately, i think I'd like to find her a 65... KX or KTM or whatever?? Cobra? Polini??

Thanks all... I'll keep dinking with it!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×