Silicone colored radiator hose?

Anyone run the knock-off colored radiator hoses from ebay? I have a friend that said they work great and another that said they are junk. I personally do not like to buy from china but for a savings of $100 I will.

I have a set on my CRF and have no complaints ecspecialy for the price

My wife has had them for about 6 months on her RM, they seem to be holding up fine. They were the wrong lengths so we had to cut them back but other then that no problems.

I have them on my Yz... as stated above they were a little long so I had to cut them down but they are holding up great. Even have a couple REALLY hard get offs and no damage done to them, my Rads on the other hand not so much luck so now Im running the knock off oversid rads as well off ebay.

There's a big thread all about it if you search, the ebay knock offs, ASI are said to be decent but I don't have any personal experience with them. If I were to buy a less expensive set I would look into Moto Hose. If you're in no rush, and look around for awhile you can score the expensive ones for cheap like i did (Pro Circuit or CV4). found a brand new CV4 Y kit for my 09 for $85 shipped. Its regularly a $215 kit.

About a year ago I bought some ASI one piece Y hoses for about $55 delivered. One tube needed a little shortening, but I guess they make them a little long just in case. After about 60 hrs they are holding up fine, and that includes a hot summer. If one blew out soon, I'd just buy another set. Cannot complain.

I have also used them with no issues.

yep running ASI off my recent rebuild and I have no complaints.. When you install them becareful because they might be a tad long.. If they are too long they will pinch the hoses shut and reduce the coolant flow.

I took a razor and trimmed off the edges of mine so that i could pull the hoses tight and they have been just fine. Like it was said its better to have them too long than too short.

yep running ASI off my recent rebuild and I have no complaints.. When you install them becareful because they might be a tad long.. If they are too long they will pinch the hoses shut and reduce the coolant flow.

I took a razor and trimmed off the edges of mine so that i could pull the hoses tight and they have been just fine. Like it was said its better to have them too long than too short.

Exact same thing for me. The ASIs have held up well and look great. No issues, other than trimming one of the hoses down a bit. Make sure you get the Y kit. Got mine on flebay for about $35 shipped.

^^^^^ what they said

I was looking into getting a pair of the ASI silcone hoses off of ebay an i noticed that they advertise them for KTM 02-06 525EXC and i have a 01 520EXC and i know that the motors in these bikes were pretty similar from 01-03 is when they changed.... does anyone have some solid feedback on if this "02-06" hose will fit my 01?!

Try the KTM forum or ktmtalk.com. I have no idea.

yeah i did just figured since it was on the subject i would give it a shot.... thanks tho! =)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now