Have a got a poblem looming?

Hi peoples,

I have been doing some electrical work on my 2010 x. As we all know, to get 12vdc running you have to start the engine. I did this and was metering a few things and the bike started to heat up a bit. Nothing too hot though, i would expect it to get hot just sitting there idling away. The potential problem that i am worried about it that i spotted transmission oil dripping out of an overflow tube. I have some marine carpet under the bike which soaked up a puddle.

I am really worried that this is not at all normal and that i have a problem.

Can anyone shed any light on what this may be and what i might need to do to fix this?

Any help you guys out there can offer would be greatly appreciated as always.

Thanks TT

Hi peoples,

I have been doing some electrical work on my 2010 x. As we all know, to get 12vdc running you have to start the engine. I did this and was metering a few things and the bike started to heat up a bit. Nothing too hot though, i would expect it to get hot just sitting there idling away. The potential problem that i am worried about it that i spotted transmission oil dripping out of an overflow tube. I have some marine carpet under the bike which soaked up a puddle.

I am really worried that this is not at all normal and that i have a problem.

Can anyone shed any light on what this may be and what i might need to do to fix this?

Any help you guys out there can offer would be greatly appreciated as always.

Thanks TT

Do you know which tube?

There is no over flow tube on the X.

There is a crank breather and a head breather, but they go up, not down.

You should have a clear 'condensation hose' with a plug in it, that will collect oil and water vapor.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now