Jump to content
Sign in to follow this  

tired of being flashbanged

Recommended Posts

Hello all,

I have a 79 suzuki PE 250 its a two stroke and it keeps back firing! it only happens when i kick it. it wont start even when i drop into gear. any suggestions? i replaced the head gaskets and redid the carb and had it running after both but then it died and started the backfiring... please any help appreciated.

Thanks

Share this post


Link to post
Share on other sites

Either your sparkplug is bad or your flywheel key broke and the spark is out of time. Take out the sparkplug and see how it looks.

Share this post


Link to post
Share on other sites

It's gotta be an ignition issue. Backfiring is a common issue when the timing is off. Coviello is right to check the flywheel.

Share this post


Link to post
Share on other sites

it did turn out to be the plug. although i had just put a new one in about a week ago. I did find a crack in my carb intake boot so I think the extra air must have fried it. Thanks for the help

Share this post


Link to post
Share on other sites
it did turn out to be the plug. although i had just put a new one in about a week ago. I did find a crack in my carb intake boot so I think the extra air must have fried it. Thanks for the help

The extra air might have fried more then the spark plug. Being the bike is that old, might be time for a leakdown test. Maybe even replace all the gaskets and seals anyhow just to be safe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×