Throttle Help 2003 CR125R

I have a friend who bought a used 2003 CR125R several years back. He pretty much left it at my house about 4-5 years ago / has never ridden it since so I'm basically considering it my spare bike to take any of my friends riding whenever I need a riding partner who doesn't own their own bike. He's okay with that and I told him I'll fix what is needed, etc. Last time I the bike was ridden was about 3 years ago. I had replaced the throttle housing with some cheap Motion Pro item because the tube the grip covers was all chipped and cracking. I don't remember if it was ever ridden with the new MP throttle, but the throttle was kind of sticking / just not returning. It was so long ago, I'm thinking I just said screw it until a later date (and now it's that date). So, I just bought new Boyeson reeds, a FMF Spark Arrestor, DID Chain, Air Filter, Some misc OEM parts, carb return spring, and Motion Pro throttle cable (part 02-0384) [stock cable just didn't seem all that smooth after cleaning and lubing]. I tried putting the cable into the throttle housing and with all the adjustments (top of carb and throttle housing) maxed, I still have about 1/2-3/4" play. I'll mess wiht it some more, but I'm pretty sure I had the throttle in the housing properly. I'm guessing I will just have to buy a better throttle; any suggestions on a replacement. I can't find any of his old OEM throttle parts, and buying new OEM would be pretty spendy. I have probably spent about $300 on his bike recently and don't really feel like spending any more right now if I don't need to.

Another option could be that if I take my throttle from my 2004 CR250R and place it on his 03 125R (would that work - cable length, etc.,), and I could get me something a lot better (I'd rather do that than buy him a real good one).

I have pretty much done all my own work, suspension / motor, etc. for 25 years.. this is just kind of irking me.

check your manual to see if you routed the cable properly. I use Mp tunes and they are as good as OEM. Does the MP cable match the cable you removed?

I'll check that tomorrow. I'm kind of thinking the OEM Honda Throttle assembly sucked up that other half inch or so. I think the ends of the cable are at the correct length, it's just the cable jacket is too short.

If thats the case..use the old cable and cut enough of the casing then slit it and add to the carb cap end....not ideal but can work.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now