Need Some Troubleshooting Help

06 kx250f

So I went out trail riding today, did about 10 miles and the bike ran great. Then coming up a long, but not extremely steep hill the bike started losing power. Made it over the hill and when I was stopping the bike cut out. I noticed that my oil was a little low just at the bottom of the sight glass. It seems like some oil blew out the breather. I haven't been able to get the bike started since. It has a spark but it looks pretty weak. Its definitely getting fuel. I even pulled the air filter and tried some starting fluid, it did nothing. So if anyone has some ideas please tell me where I should start looking?

Test the stator per the manual. Also, pop the oil filter out, check for debris.

Could check the CDI box to, that's what happened to mine when it did the same thing your did. I ended up losing a ground bolt to the wiring harness and didn't realize it, fried the box!! Good luck

Could check the CDI box to, that's what happened to mine when it did the same thing your did. I ended up losing a ground bolt to the wiring harness and didn't realize it, fried the box!! Good luck

Is there a way to test the cdi?

Sadly no, I got lucky and had a extra one laying around. You may be able to take it to a dealer or if you can find someone else with a 06-08 that would work to.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now