2008 xcf 450 with 505 kit

so i just got my bike out of the shop yesterday with all new motor was breakin it in yesterday let it run for 5 min then cool down then run 5 cool down etc.... then went to ride it and it just keeps diein runs for a few min then just shuts down like someone hits the kill button ? any sugestions im reallystarting to not like ktms!!!

You should start to not like the shop that did the work instead. Go back there with the bike and let them sort it out.

You should start to not like the shop that did the work instead. Go back there with the bike and let them sort it out.

Ville,

Any chance this could be the result of the motor being new and extremely tight? My new bike was tempermental (stalling, starting hard) for about a half hour before running consistent and like what you'd expect. My buddy experienced the same thing with his new 350.

Never had that kinda problem on any (and i´ve had maaaany) of my new KTM´s. They don´t run at their best before some hours on the engines but sudden engine deaths ?? Never experienced that myself.

You should start to not like the shop that did the work instead. Go back there with the bike and let them sort it out.

I agree with VilleKTM, take it back to the shop that did the work. People assume that because they had the work done in the shop that it was done correctly and that is not always the case. Find a "Good" KTM mechanic and stick with em, and you will love your KTM as much as I do mine...:smirk:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now