XR650R engine cutting out 4000-5000 rpm

I’ve got a 2002 XR650R with an FMF Hi-Flo header and Q2 exhaust. My jetting is:

175 main

B53E 3rd clip

68s pilot

4000 ft riding elevation.

When I reach 4000 rpm or so the bike sputters and loses power. I’ve gauged this around 4000-5000 rpm, but I think it starts to do it worst around 4500. It does this with half throttle or wide open throttle, so I’m not sure it’s a jetting issue. Otherwise the bike runs great at all other RPMs, even higher RPMs. I’m wondering if it could be an ignition thing, but not sure if this makes sense? Any advice?

Mine did that at 3800 ft with a 172 main. ,,when i had a stock carb..

I went down to a 168 and it ran perfect.

Also, run a full pipe system and completly opened up.

I'll give it a shot. Doesn't seem like jetting though since it doesn't very with throttle position, just RPMs.

I am running the stock carb though.

I'll give it a shot. Doesn't seem like jetting though since it doesn't very with throttle position, just RPMs.

I am running the stock carb though.

For reference, I'm running a 168 main, but in Baja I put in a 172. Never noticed any issues.

As you know, I'm running stock, uncorked exhaust.

If you want, I have a 170 main you can try.

sounds to me like CDI

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now