carb help

Ok I just installed a mikuni carb on my sons Yamaha 125. Bike starts right up idle nice. Here's the issue. If I pull slowly on the throttle its ok but if I pull quick it bogs out. I have tried all clip setting no change. Any advice would be wonderful. Maybe its happend to you and this could be a quick fix. Rejet?????

Most will 'bog out' when revved on the stand. Ride it & see how it goes....

Ok I will give it a try thank you,

What kind of 125? YZ or a TTR? If its a thumper...ya, wacking the throttle wide on that lil motor is going to kill it usually.

Its a 2001 TTR-125 from idel to a quick pull on the throttle it cuts out.

Ok I just installed a mikuni carb on my sons Yamaha 125. Bike starts right up idle nice. Here's the issue. If I pull slowly on the throttle its ok but if I pull quick it bogs out. I have tried all clip setting no change. Any advice would be wonderful. Maybe its happend to you and this could be a quick fix. Rejet?????

are you sure you have the right jet??? I had a ktm 380 and changed the clip settings from 0 to max and had the same issues. Ended up being that my jet was a 165 and needed to be a 142 (bought the bike used in a different state).

If you know anything about carbs, I would check with guys that run that same bike at your elevation and make sure you have the correct jetting.

Good luck!

The main jet is a 102.5 and pilot is a 17.5 I'm so frustated I mean it can't be that hard to figure out. And I don't want to take it to the dealer.I'm in Sacramento

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now