Why cant i find the power band

Okay i ride a 1985 CR125R. (TwoStrokes Or No Strokes) Anyways i went riding a month or so ago (haven't been able to because of weather) anways i hopped on her yesterday to ride her up the street and i cant find the power band, i can feel where it should be, but its like it lags out.. I changed the plug and that didnt help. My dad dosen't want to mess with it until we have a place legal to ride it because here its illegal to ride on the road. this is bugging me bad. Please tell me what this could be.. i need the power band ): :ride:

do a compression test. should be above 120 and below 180 ( i think ) if its stock. maybe the carb needs to be cleaned also.

yeah you are way to lean on your main or your bike has no compression. Is it hard to start?

Maybe your need to adjust your valves? Or you may need new graphics.

Much stickers add much fasterer. Kj55 right.

i had the same prob, went out and bought a new band, went with the red one.

your clutch is worn out. replace with tusk spring and plate set. my 125 did the same thing

needs a new top end rebuild

Throw one of those fancy KTM powerbands in there, she'll scream.

Okay i ride a 1985 CR125R. Anyways i went riding a month or so ago (haven't been able to because of weather) anways i hopped on her yesterday to ride her up the street and i cant find the power band

Check under the seat! On those bikes, the powerband is usually located under the seat.

:ride:

Clean your powervalve, it's probably all gummed up and not functioning!!!!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now