Jump to content
Sign in to follow this  

1989 KX125 blowing white smoke

Recommended Posts

Picked up an 89 KX125 not running and got it cleaned up and got it running but, it revs up and down by itself randomly and it is blowing white smoke out of the tailpipe. Also I pulled the pipe off to take a look and the pipe itself had ALOT of water/oil in it, it was like pouring out a large glass of water. So I'm not sure where to start... Otherwise the bike starts and revs normally but the smoke is excessive and im wondering if maybe the crankcase has the same water in it like the pipe and how did all that get there???

Share this post


Link to post
Share on other sites

Radiator? Maybe someone put water in without antifreeze and it froze and cracked the engine allowing water in. Check the rad to see if it has coolant or just water.

Share this post


Link to post
Share on other sites

Hmm, the kid said the person he got it from had put a new top end in it, maybe they used the old gasket and it is broken or crapped out. He also said that it ran great until he mixed his own gas to put in it, apparently he used ENTIRELY too much oil because when I drained the old nasty gas out of the tank, it looked like he got the ratio backwards haha looked something like 1:32 instead of 32:1 hahaha seriously.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...