Jump to content
Sign in to follow this  

TT600 Belgarda

Recommended Posts

Hi guys, new to this so please be patient.

Just purchased 1999 TT600 Belgarda (cheap)

Problem is it won't idle and you have to blip the throttle to keep it running.

Backfires continually and not sure where to start, previous owner left it sitting in the shed for ages and says it didn't do this before.

Any help would be appreciated.

Share this post


Link to post
Share on other sites

Welcome .

Probably better pull the carb(s) and clean the mung out of every passage and jet , particularly the idle circuit . The backfire is indicative of bad insulators ( rubber and metal parts that connect the carbs to the head ) allowing air in , leaning the mix .

Share this post


Link to post
Share on other sites

Started on the carby and found the mixture screw is MIA. Tried one from an earlier model but still playing up, could mixture scews be different between models or should I be looking further.

Share this post


Link to post
Share on other sites

What carb does the earlier model have compared to your bike ? I suppose they could be different , but from the pics I've seen they seem very similar . I haven't found any parts fiche to verify model usage . I did find a service manual for a 2003 model ( wouldn't think there would be much difference from a 1999 ) that you might be interested in :

http://issuu.com/nanorecius/docs/1_yamaha_tt600re_5ch5_2003_service_manual

Share this post


Link to post
Share on other sites

Pilot jet blocked and mixture screw is model specific. Can't find one in Adelaide so have to wait for one from Sydney.

Thanks for the help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...