Jump to content
Sign in to follow this  

KLX110 motor build issues

Recommended Posts

I'm having some issues with a 110 motor build. I've built a few of these bikes before and a handful of 50's so I have some idea of what I'm doing. I have a 55m trail bikes crank with a stock cylinder and piston, and a stock head with a BBR cam and BBR heavy duty valve springs. When checking the timing per the service manual- (rotating crank counterclockwise two rotations) the valve slaps the piston. I had a friend who has also built a 110 double check my work, we tried flipping the cam as the service manual is a little vague in direction of lobes and the same issue still occurs. We're confident it's not the bottom end because the crank rotates easily with the cam chain off the cam sprocket.

Is it possible the BBR cam and stroke length of the 55mm crank are not compatible in a stock cylinder? I'd really appreciate any other ideas we're stumped.

Share this post


Link to post
Share on other sites

E-mail Mike at TrailBikes: hondatb@aol.com

You might need a different piston w/valve reliefs for the stroker crank.

Or try it with two base gaskets first.

Share this post


Link to post
Share on other sites
E-mail Mike at TrailBikes: hondatb@aol.com

You might need a different piston w/valve reliefs for the stroker crank.

Or try it with two base gaskets first.

If that's the case I wish someone would have told me that when I ordered... I emailed him the same time I posted this last night.

Thanks

Nick

Share this post


Link to post
Share on other sites

did you let them know the motor setup you were using? Try sticking another base gasket on there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...