Jump to content
Sign in to follow this  

2005 yz250f SOME ONE PLZ HELP ME OUT HERE !

Recommended Posts

friend of mine picked up a 250f with no spark......balance gear broke and when fixed the shop didnt flush all the pieces out and stator fried......

...new stator.....1 day,,,,,,then no spark,

flushed many many times,,,,,another new stator,,,bike would run till warm then only push start,,,, then nothing......then if he would un-plug and re-plug some wires it would start,,,,but then that failed too...

ordered a whole wiring harness/coil/cdi off ebay and well ran for 5-10 minutes then dies again,,,,,cooled for a little bit then fired back up !

so it seems that this bike will only run/fire/spark when cold...and die when warms up !

:smashpc::banghead:👍:banghead::busted::banghead:🤣

this guys been working on bikes for 20+ years so hes pretty stumped !

Share this post


Link to post
Share on other sites

o through and check all the electrical components and check for those wire and test them to make sure they are working. then checck and make sure grounds are correct(if there are grounds) then go through and clean all the connections and put some dielectric gease on the connections. and dont forget to put a new plug in!!!!!!!!

Share this post


Link to post
Share on other sites

Uhmmm have you checked your jetting or cleaned the carb? If it starts fine cold but not warm it's usually running rich. Might want to see what jets are in there and adjust your idle mixture screw unless you know for a fact that it's not getting spark when hot. Is the ground strap still connected to the head? Cam timing still dead on? Start back at the basics and move from there. Also when buying used off the Internet you may be buying somebody else's headache. It could be you bought a bum part. The best way to troubleshoot these electrical problems is to borrow parts from a known good bike then go from there. (Hint, that only works if something isn't frying your parts as you put them on. If that's your case then the guy you are borrowing parts from will be PISSED that you fried one of his parts.) Check all grounds!!!

Share this post


Link to post
Share on other sites

the spark will disapear !

then change out stator/elecs and itll work till bike warms up then nothing again,,,no spark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...