Jump to content
Sign in to follow this  

250sxf wont start with sxs-f cdi

Recommended Posts

I have a tuned 2007 250sx-f which has a Vortex cdi unit. The Vortex cdi is standard and with it fitted my bike starts Ok and runs very well.

I also have a 2007 250 sxs-f cdi unit which I bought brand new a few years ago. At that time I used it very briefly and it also worked fine, however, it didnt perform quite as well as the Vortex so I put it back in its box to keep as a spare.

Recently I decided to try the sxs-f cdi again. Since I originally tried it my motor has been modified further so I was interested to see how it now perfomed compared to the Vortex. However, with the sxs-f cdi fitted my bike refused to start with the kick starter or when being bumped off. With the Vortex cdi refitted it fired straight up first kick.

I cant see that there could be a problem with the almost brand new sxs-f cdi unit and everything was connected up properly so I aren't sure why it wouldnt start. Any one got any ideas??

Share this post


Link to post
Share on other sites

Well, if it doesn't start with the SXS cdi but does with the Vortex, why wouldn't you think the SXS box wasn't faulty? It's not like you can plug it in wrong.

Share this post


Link to post
Share on other sites

Thanks for the reply.

I am assumming that the cdi is good because when I originally tried it I literally used it for no more than 5 mins. At that time it worked absolutely fine. If you look at it now it looks brand new, you couldnt even tell its been on a bike. I cant see how it could have gone faulty whilst being stored in a box for a couple of years.

Share this post


Link to post
Share on other sites

I don't know how it could go bad either but it's the only thing that makes sense. Do you know anyone with an 07 or 08 250 you could try it on?

Share this post


Link to post
Share on other sites

Thanks, that was going to be my next step. Will have to track someone down with a similar bike though.

Hopefully it will prove that my cdi is fine. Will be disapointed if the cdi has gone bad after such little use.

Share this post


Link to post
Share on other sites

Both cdi's connect to the oem wiring harness via the same oem connector plug. I simply removed the vortex cdi from the bike and plugged in the sxsf cdi just as I did when I originally tried it.

Share this post


Link to post
Share on other sites

Further to my recent posts, the sxs-f cdi has now been tried on another bike and that bike started fine and ran perfectly with it fitted.

A bit puzzled why it wouldnt start when fitted to mine. Any ideas??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...