Jump to content
Sign in to follow this  

'12 Engine light question

Recommended Posts

I noticed last night at practice (I just recently changed my oil) when I start to get in the higher RPM's (really rev the bike), the engine light will momentarily come on then go off...I tried looking in the owners manual for that specific warning, but I can't find anything....odd? 👍

Share this post


Link to post
Share on other sites

Assume you are talking about the light for launch control? I have noticed mine goes on and off at strange times, it will always light when kicking the bike over and even after hitting the kill switch and the motor dies it lights up for a bit and then goes off. If it functions correctly otherwise I would not worry about it, is the bike running fine?

Share this post


Link to post
Share on other sites

Ya, the light for the launch control. In the owner manual it says that if it lights up (gives a specific sequence, etc) then there is a problem. Bike seems to be running ok...The idle was low when I bought it from the dealership, and I still occasionally stall it in the corner (Maybe its my fault as well). I just thought it was odd when I get the bike in the higher RPM's, and start to get a little hard on it, the engine light momentarily pops on....who knows. I just broke it down today, and did not notice any loose connections, etc.

Share this post


Link to post
Share on other sites

I will pay more attention to it while running it next time, normally I am too busy trying to hold on to the beast! As stated mine does not blink but it does go on and off during startup and shutdown, it functions as stated in the manual when using he launch control.

Share this post


Link to post
Share on other sites

There is a connector on the left side that can be disconnected while idling and It will flash the diagnostic codes..

Share this post


Link to post
Share on other sites
Ya, the light for the launch control. In the owner manual it says that if it lights up (gives a specific sequence, etc) then there is a problem. Bike seems to be running ok...The idle was low when I bought it from the dealership, and I still occasionally stall it in the corner (Maybe its my fault as well). I just thought it was odd when I get the bike in the higher RPM's, and start to get a little hard on it, the engine light momentarily pops on....who knows. I just broke it down today, and did not notice any loose connections, etc.

You can adjust the idle by turning the choke knob.

Share this post


Link to post
Share on other sites
You can adjust the idle by turning the choke knob.

Yep, I got that...still playing around with it. I just want to make sure its not 'pilot error' 👍

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...