Jump to content
Sign in to follow this  

07 KTM 65sx

Recommended Posts

hey guys...i'm new to KTM's. Just got my 9yo son a 07 65sx. He loves the bike! I however feel like the clutch is slipping. Can someone reccomend or direct me to a post about oil as well as details on how/when/type of oil to use? I know it's a hydrollic clutch so is replaceing it more expensive or are there adjustments that can be made? I also run Motul 800 at 40:1 and it's been a while since i have been in the 2-stroke scene...but this 65 seems to be leaking alot of oil out the pipe. any cleaning tips for the plastics?

thanks!

Share this post


Link to post
Share on other sites

I run my boys bikes at 36:1. Try changing the o-rings for the exhaust. You have to run mineral oil in the hydrolic clutch itself but in the transmission I run Mobile 1, 0w30 motorcycle oil.I run dirt digger clutch seems to work great. There is no adjustment for the clutch only the lever

Share this post


Link to post
Share on other sites
hey guys...i'm new to KTM's. Just got my 9yo son a 07 65sx. He loves the bike! I however feel like the clutch is slipping. Can someone reccomend or direct me to a post about oil as well as details on how/when/type of oil to use? I know it's a hydrollic clutch so is replaceing it more expensive or are there adjustments that can be made? I also run Motul 800 at 40:1 and it's been a while since i have been in the 2-stroke scene...but this 65 seems to be leaking alot of oil out the pipe. any cleaning tips for the plastics?

thanks!

In the gearbox, use Maxima MTL 80, as for the hydraulic clutch fluid,. I have always used the Motorex mineral oil, but many use baby oil too. Mix ratio on fuel, I'd use 3 oz per gallon, ie 44:1 and ron Motorex Cross Power T

Share this post


Link to post
Share on other sites

I think the fluid level on the lever is fine. I was and am more concerned with what weight/type of oil to run in the gear box and if the old oil in there would be causing the clutch to "slip"?

thanks!

Share this post


Link to post
Share on other sites

I run Dexron VI ATF in all my KTM's, including the 65. Could be the clutch pack needs replacing. The one thing I don't like about those year models is you have to drain the coolant to get to the clutch.

My 200's clutch was slipping bad when I got it. Installed the Tusk kit from RMMC and all is good.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...