Jump to content
Sign in to follow this  

DRZ400sm stumbling upon acceleration.

Recommended Posts

I recently had some electrical trouble and had a local shop install a new stator from ricky stator. Ever since the new stator has been installed I've been experiencing some strange stumbling while accelerating.

It's hard to say without a tach but I think it is happening around 4000 - 5000 rpm and continues unless I give it more gas. It happens more if I'm accelerating hard, If I am easy on the throttle everything runs silky smooth.

So far, I've drained the float bowls, added seafoam to the fuel and changed the plugs but the problem persists. Could this problem be caused by the new stator which was installed? I called the shop that installed it and they tried to tell me that there was no way that anything they had done could be causing this. I'm pretty sure that they will look into it If I take it back there but I don't want to be a problem customer and hold them responsible for something that was merely coincidental.

Share this post


Link to post
Share on other sites

My old DRZ had a midrange stumble much like you describe. So you have any carb mods or airbox mods done? Mine turned out to be that the previous owner tried to do a 3x3 airbox mod and made it more like 4x6

Share this post


Link to post
Share on other sites

Yep, I've done the 3x3 to it and rejetting the carb. however I don't believe that this is the problem because it ran beautifully for 4 months after I did the 3x3 up until I had the new stator installed.

Share this post


Link to post
Share on other sites

Sounds like it may be related to the stator as it's been like it since the install..

Just to cover the jetting side....what's your location, altitude, mods and current jetting...?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×