Jump to content
Sign in to follow this  

YZ250F - Hanging idle SOLVED...by accident!

Recommended Posts

Hey all!

This post comes as more of a curiosity about why it worked rather than a how to thread. I apologize for the long post, but if someone can benefit from my experience, then I can finally give back to these forums that I have benefited from for so long.

For those that don't want to read the drivel below, skip to the end and see what the hell I did, and tell me why it may have worked. :thumbsup:

Background:

04 YZ250F - Stock engine, White Brothers Slipon, jetted for our riding altitude and hot summer temperatures.

The bike sat for about 6 months, unfortunately without any prep. (damn kids! :worthy:)

After thouroughly cleaning the fuel system and cleaning the carb inside and out, replacing every jet (yes, ALL of them), replacing hot start cable/plunger, adjusting valves, checking cable slack...

I still had a FREAKING HANGING IDLE!!!!!!!

And it ran like shit! I couldn't dial in the idle circuit to save my life! :worthy:

One last thing I checked was to make sure I didn't put the slide in wrong... I was pretty confident I hadn't, but hell, maybe I had one too many beers that night... :worthy:

...it was in correctly. Whew! :worthy:

After putting the bike back together for the last freaking time :ride:, on a whim, I decided to check for cracks in the intake coupler. Got out the starting fluid...fuel screw at 2.25 turns, petcock on, a couple soft TDC kicks, one hard kick, and it fired right up, and purred like a kitten!!! I turned down the idle a bit, let it warm up a little, blip, blip, blip the throddle...

NO MORE HANGING IDLE!!!!!!

SOLUTION:

What the hell did I do? I had no idea...

Until my son pointed out that I had neglected to connect the TPS!:worthy:

OK, I know the bike will run ok (sort of) with the TPS disconnected, but it sounded so smooth... like the day I got it. I ran it around the block (5 miles) to check out all the circuits, and it ran great! Holy crap!

Wait... it gets better...

After the warm-up, I plugged back in the TPS expecting it to run like crap...and it started first kick, and ran just as good!!!

Several rides later, and it still runs great...

What the hell is going on?????

Can anyone tell me why this might have happened? I know the TPS plug is clean and I seated it properly EVERY time I replaced the carb, except the last time, obviously.

DID the CDI somehow reset? I'm trying to understand...

Thank you in advance,

- KeVin

Share this post


Link to post
Share on other sites

My 04 runs like poop with the TPS connected. It's been quite a long time that I've had it disconnected now. As far as why it does that it has to do to ignition settings. The TPS has no affect on the fuel circuit. Could be a problem with the sensor or the CDI. The TPS may need adjustment or a new one. There have been guys here on TT that had similar problems and replaced the TPS and the problem was still there. The CDI will resort back to a set setting when it does not see the TPS input. If it sees the TPS input then it wants to use that reference for it's ignition setting. With the TPS disconnected you may see a difference at high RPMs but I never did so I left mine unplugged.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×