Jump to content
Sign in to follow this  

2011 crf 450 BAD BOG

Recommended Posts

I have a 2011 crf450 and its got a bad bog at the crack of the throttle..had in the shop they claimed the fuel injection was bad..after that, the problem was still there..they also said that it was the yosh exhuast and the pmi 2 box..which doesnt make any sense..any help would be greatly appreciated thanks.

Share this post


Link to post
Share on other sites

Sounds like it could be a TPS issue or adjustment. Does it ride ok? Clear up above part throttle? What are all the issues you're having?

Share this post


Link to post
Share on other sites

Well from close to about quarter with a quick snap it bogs really bad. it runs really well its jsut the throttle response the thing only has 6 hours if that..its got full yosh system and the pmi 2 box.. its done it from day 1

Share this post


Link to post
Share on other sites

mine did that bone stock until I sent my ECM out to Eddie Sisneros.

No more bog

No more flame out

Share this post


Link to post
Share on other sites

Yeah the ECM is key. Getting that done should help.

Also, EFI bikes (in my experience, no scientific data to back this up) must be completely warm before they run correctly, so make sure your bike is at operating temperature.

Share this post


Link to post
Share on other sites

Just had the same problem with my 11 CRF450. I was at the track and ran it out of gas, from then after I had a bog. I changed out the fuel filter inside the tank and the bog went away. I'm not sure if that was it or there was a air bubble in the system. But whatever it was, it seem to fix it. It really sucks when jumping and the bike doesn't respond the way tou want. Good luck!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×