Jump to content
Sign in to follow this  

noob needs help

Recommended Posts

I have an 05 crf250 and I have noticed that whenever I hit a jump I dont launch like everyone else Im riding with, I have to be hard on the throttle to be able to clear while they just kind of coast through even though we were going at the same speed before the jump. I dont know if my suspension is just not compressing on the face of the jump or what...I had everything resprung for my weight and my sag set...any suggestions would be appreciated

Share this post


Link to post
Share on other sites

Give us some info on the suspension settings. Spring rates, your weight. Who valved it?

Too soft? Sounds like a rebound issue too

Share this post


Link to post
Share on other sites

.40/ 4.6 im 120 no gear. A friend of a friend who has a small shop did it locally... My forks compression are set pretty stiff could that be the problem?

Share this post


Link to post
Share on other sites

Have you tried it on one of their bikes? It could be that you're just not holding the throttle all the way through the jump.

Share this post


Link to post
Share on other sites

the bike with reb closed don t spin the bike on jump and you need more speed !!!try to open the click on reb ,expecially on shock.but remember the bike with less reb is more instabil and it s good when the bike don t spin you high and forward on jump you have more control

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×