Jump to content
Sign in to follow this  

11 TE310 Cam Chain Noise

Recommended Posts

Its seems like from day 1 my cam chain makes some loud noise. Is it normal or do I need to tighten it? I thought these have the auto tightening? Or maybe they are just on the noisy side?

Share this post


Link to post
Share on other sites

Hey,

I have a new 2011 TE310 with 18 hours on it now. makes a little noise but I think it is caused by the cam gear design (gears not driven by the chain directly) causing a "whirring" type noise. If yours sounds like mine then I think normal condtion.

**loved your vids.

L.

Share this post


Link to post
Share on other sites
Hey,

I have a new 2011 TE310 with 18 hours on it now. makes a little noise but I think it is caused by the cam gear design (gears not driven by the chain directly) causing a "whirring" type noise. If yours sounds like mine then I think normal condtion.

**loved your vids.

L.

I will video the sound later.

Thanks

:busted:

As for the videos we been riding some screwed up suff so saving the TE. I cant abuse it yet....

:busted:

More videos here..

http://www.youtube.com/user/drjekyll808?feature=mhee#p/a

Share this post


Link to post
Share on other sites

My '11 te310 with 35 hrs has always been a bit noisy. I think those big cams in the x-lite engine normally make a little racket.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×