Jump to content
Sign in to follow this  

Stuck Well Cleaned PV?

Recommended Posts

Hey all I have a PV I recently took apart off of my 93 cr250. It had a lot of crap on it so i soaked it and scraped it all off. After reassembly I can manually move the pv through it's entire range of motion with the linkage, but with the engine it won't shift out of L to H? As if the gov. was not working......?

Share this post


Link to post
Share on other sites

your probably not aligned correctly. the crows foot at the bottom of the cylinder has to engage with the pinion shaft, see your owners manual

Share this post


Link to post
Share on other sites
But I didn't take apart my cylinder head!

Then how do you know if it was aligned properly? I suggest taking it apart and going from there..........it's the only way to know for sure!

Share this post


Link to post
Share on other sites
Then how do you know if it was aligned properly? I suggest taking it apart and going from there..........it's the only way to know for sure!

But I didn't take it apart in the first place, can they misalign on their own?

Share this post


Link to post
Share on other sites
But I didn't take it apart in the first place, can they misalign on their own?

You just got this bike correct? When is the last time it was dis-assembled? Has the PV ever worked for you?

It won't work if it's not aligned properly, you've got to start somewhere to troubleshoot this, this is the next step in understanding what is going on with it.....

Share this post


Link to post
Share on other sites

actually, I don't think you have to take the cylinder off for it to be out of alignment. if you moved the drive shaft around (or lifted it and set it back down in) when you cleaned it, that could have done it.

Share this post


Link to post
Share on other sites
Okay I'll take it apart and let you guys now how it goes. Thanks again.

Good Decision! Make sure you have got a new gasket kit as well.......

Share this post


Link to post
Share on other sites
Good Decision! Make sure you have got a new gasket kit as well.......

Yeah as you all suspected it had been in the direct wrong position! How it got over there I don't know. I've also decided to do a new top end!

Share this post


Link to post
Share on other sites
Yeah as you all suspected it had been in the direct wrong position! How it got over there I don't know. I've also decided to do a new top end!

Nice!!! Now just take your time when putting it all back together and don't force anything into place as you don't wanna bust one of the crow's feet........Make sure you put some grease in there too!

btw - where in cali you at?

Share this post


Link to post
Share on other sites
Nice!!! Now just take your time when putting it all back together and don't force anything into place as you don't wanna bust one of the crow's feet........Make sure you put some grease in there too!

btw - where in cali you at?

SF Bay how about yourself?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×