Jump to content
Sign in to follow this  

metal in the oil screen

Recommended Posts

Wow 8k on the engine first time i checked the oil screen .Was very clean besides about 10-15 metal shavings and a few black ones as well .shavings were about 1mm long, oil had about 2 k on it ( I know I was bad for letting go that long).The engine has had a full clutch kit about 2 k ago. give me some opinions on what to check or should i ride and check it after next ride.It does have slight tick in the engine so I bought some cams since i figured i would be adjusting valves. Could metal be from old clutch? Maybe i'll pull valve covers tomorrow and look . I feel sick and confused I guess I'll sleep on it. :busted::banghead::busted::banghead::bonk::banghead::lol:;):foul:

Share this post


Link to post
Share on other sites

thanks guys/ yes first time since new.and I'm also hoping fresh oil relieves the ticking. I guess I'll oil it up and ride this weekend thanks again

Share this post


Link to post
Share on other sites

mines now on 41000 miles , i change my oil every 500-800 miles ive only once had bits of metal on the screen and that was around 30000 miles , i think to a point you are going to get some now and again id not worry about it unless you get some strange noises. Dont skimp on oil changes.

Share this post


Link to post
Share on other sites

thanks packman I do oil changes every 1000 except for last been busy or traveling so just rode and neglected . I must stay on top of it and locktite fixes on the way I've had to many good rides to loose it now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×