Jump to content
Sign in to follow this  

tail light stays on

Recommended Posts

Had an issue a couple months ago and just got around to looking at it. After we finished a DS ride at Bass Lake I noticed my tail light was still on. Trick DS kit was off but two LED's were still it. I could not turn it off and since most of the LED's were burnt out I just cut one of the wires to not drain the battery.

So I got a new tail light from CRF's Only, the one that's brake and tail combo. It can't wire in the same as the original doesn't use a ground and doesn't have a stop light so I tied the new one into the Trick harness so its parallel to the Trick tail/stop light/license plate. All works just fine but must have the Trick kit "on" to have any tail light, no biggy.

Question is why did the old one stay on? I did some testing with a test light and sure enough it's hot all the time. Looked at the wiring diagram and this light runs through the ignition module, which is what I assume completes the ground when the motor is running. I messed around a bit and found that if I substituted a ground wire for the wire through the module it was the same, always on. So bottom line is I cannot return the tail light to stock or it will be on all the time. Is the ignition module failing?

Share this post


Link to post
Share on other sites

A couple of years ago i damaged my module when I was putting in a brake light. (light stayed on) I should have disconnected the battery when installing it.

Share this post


Link to post
Share on other sites
Had an issue a couple months ago and just got around to looking at it. After we finished a DS ride at Bass Lake I noticed my tail light was still on. Trick DS kit was off but two LED's were still it. I could not turn it off and since most of the LED's were burnt out I just cut one of the wires to not drain the battery.

So I got a new tail light from CRF's Only, the one that's brake and tail combo. It can't wire in the same as the original doesn't use a ground and doesn't have a stop light so I tied the new one into the Trick harness so its parallel to the Trick tail/stop light/license plate. All works just fine but must have the Trick kit "on" to have any tail light, no biggy.

Question is why did the old one stay on? I did some testing with a test light and sure enough it's hot all the time. Looked at the wiring diagram and this light runs through the ignition module, which is what I assume completes the ground when the motor is running. I messed around a bit and found that if I substituted a ground wire for the wire through the module it was the same, always on. So bottom line is I cannot return the tail light to stock or it will be on all the time. Is the ignition module failing?

Yes, you need a new ICM. I've seen this on two 450x's. Seems to happen when moisture gets inside of the ICM.

Share this post


Link to post
Share on other sites
Yes, you need a new ICM. I've seen this on two 450x's. Seems to happen when moisture gets inside of the ICM.

Does that mean the ICM is subject to failure (will it die soon)?

Sure hope not, $150.00 at Service Honda!

Edited by Nayther

Share this post


Link to post
Share on other sites
Does that mean the ICM is subject to failure (will it die soon)?

Sure hope not, $150.00 at Service Honda!

Like Krannie said, you can still ride with it but you may kill your battery if it sits for any long period.

Share this post


Link to post
Share on other sites

Well I just rewired it so it goes through the same switch as the DS tail light (Trick DS kit). Works fine, hope Krannie is right, don't want to drop the coin. Bike ran good but did hiccup once or twice, then was O.K. again, I think I sucked something into the pilot but it cleared itself.

Share this post


Link to post
Share on other sites

if the tail light is run through the Trick Dual Sport Module the light should trun off with the kit. If you are back feeding electricity from the origin tail light harness then the power is coming from the bike and not the kit.

Share this post


Link to post
Share on other sites
if the tail light is run through the Trick Dual Sport Module the light should trun off with the kit. If you are back feeding electricity from the origin tail light harness then the power is coming from the bike and not the kit.

Thanks Dale, it was wired stock with the two wires going through the ICM. I got a new 3 wire light from CRF's Only and it requires a ground/run/stop wires so I just tied the stop and run into your kit and grounded the third. Now it acts like another stop/run light, seems to work just fine. I was going to call and ask if the kit could handle the extra load but since they're just LED's I figured I'd be O.K.

Six + years and your kit's still kickin'!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×