Jump to content
Sign in to follow this  

Kx 450 wont start please help!

Recommended Posts

I've got a 06 kx450f and the other night i replaced the hot start plunger and the gas hose that goes in between the tank and shut off valve. I took it for a ride the next day and everything seemed fine for the first 15-20 minutes but then i went up a sand pit and at the top i stalled the bike and now it wont start at all!.

It seems like i can kick it over twice and then the kickstart will freeze on the third kick and so on......I did notice that i had a small kink in the new gas line that i just put on so i fixed that and also put a new spark plug in but i still cant get that pig started. I checked my plugs and they are getting fuel,......I just dont know what to do next? I think i need a hip replacement also from kicking it over so many times!! Somebody please help me out!

Share this post


Link to post
Share on other sites

Try to coast start it? Check valve clearance? (not less than .005" on exhaust and .003" on intake) Check for spark? (have a friend hold onto the plug while you kick it, this is always a good life lesson :busted:) Check compression? Leak down test? (If you don't have a leak down tester don't worry, do the other checks first and get back to us) Check mechanical timing?

Maybe one of those sandpit monsters climbed into your air box? (that was a joke, but check your air filter)

For the most part your engine needs 5 things to operate as designed. Air, fuel, spark, compression, and proper timing of all mentioned.

Share this post


Link to post
Share on other sites

i would check your hot start plunger to make sure its not hung up, if the bike had no problems before i would start there

Share this post


Link to post
Share on other sites

You say on the 3rd kick it will "freeze?" It may have jumped time. I would NOT be towing it to start it until I checked this.

Share this post


Link to post
Share on other sites
You say on the 3rd kick it will "freeze?" It may have jumped time. I would NOT be towing it to start it until I checked this.

Yep, happened to me, I stalled it hard and it jumped time. Mine actually cranked and cost me 2 new valves and guides. Check the timing before you go any farther!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×