Jump to content
Sign in to follow this  

XR650R - Occassional pop/stall just off idle

Recommended Posts

I raced my XR650R last weekend in a Hare Scramble in Sacramento area (~100ft above see level). During the race it pop/died or almost died on me a whole bunch of times. Mostly it did it while idling/lugging in second gear through slow tight sections when I would just give it a little throttle.

It has always done this randomly when idling and only rarely. I'm running 68s pilot, 178 main, race needle, and 3rd clip position. uncorked, pro circuit exhaust, drilled out air box. It was ~60 degrees vs 90 or so that I rode it all summer and I never noticed the problem on the trail before (just sitting at stop lights idling for a long time).

I'm thinking either bad gas, I need to adjust the idle mixture screw, tight valves, or maybe step up to 180 on the main? Main shouldn't matter at 0-1/4 throttle I think. I adjusted the valves in the spring, rechecked them mid summer and they hadn't changed, and its only been ridden ~500 miles since.

Gas was about a month old. I'll set the idle mixture again go from there. Let me know if you have any other ideas.

Thanks

EDIT: also other than this, the bike has tons of power and keeps pulling like crazy to wide open throttle.

Share this post


Link to post
Share on other sites
I raced my XR650R last weekend in a Hare Scramble in Sacramento area (~100ft above see level). During the race it pop/died or almost died on me a whole bunch of times. Mostly it did it while idling/lugging in second gear through slow tight sections when I would just give it a little throttle.

It has always done this randomly when idling and only rarely. I'm running 68s pilot, 178 main, race needle, and 3rd clip position. uncorked, pro circuit exhaust, drilled out air box. It was ~60 degrees vs 90 or so that I rode it all summer and I never noticed the problem on the trail before (just sitting at stop lights idling for a long time).

I'm thinking either bad gas, I need to adjust the idle mixture screw, tight valves, or maybe step up to 180 on the main? Main shouldn't matter at 0-1/4 throttle I think. I adjusted the valves in the spring, rechecked them mid summer and they hadn't changed, and its only been ridden ~500 miles since.

Gas was about a month old. I'll set the idle mixture again go from there. Let me know if you have any other ideas.

Thanks

EDIT: also other than this, the bike has tons of power and keeps pulling like crazy to wide open throttle.

- change the gas- you get 2 weeks tops out of pump gas

- clean your pilot jet- it is partially clogged most likely. It it has sat for any longer, replace it.

- adjust your fuel screw

Share this post


Link to post
Share on other sites

I would invest into a carb with accelerater pump... I use to run old gas in my pig and never had problems.... Sounds like the bottom end is too lean...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×