Jump to content
Sign in to follow this  

2008 ktm 530 oil coming from vent hose

Recommended Posts

Has anyone had this issued I just did all of the oil pump upgrades with 2011 parts and it ran great for about 27 miles then saw that it was dumping oil out of the vent hose behind the starter. I am ready to get rid of this bike only had it a month and nothing but issues, anybody have any ideas thanks a lot.

Already did the search and could not find anything.

Share this post


Link to post
Share on other sites

Dumped out you could sit there at idle and watch it run out. Coasted out to a street and waited for a ride, filled it till it ran out of the check plug. Lost enough oil that I could not see it in site glass unless leaned my way a little

Share this post


Link to post
Share on other sites

The 2008 was pretty much known for issues with the right crank shaft seal. Not sure if this causes engine to transmission oil migration or the other way. Probably a good place to start though. Was there a problem before you did the oil pump o-ring/gear upgrades?

Share this post


Link to post
Share on other sites

Make sure that the trans drain bolt screen is clean, the one next to the engine oil drain bolt. Mine was doing the same thing, oil flowing out of the vent tube at an alarming rate. Turned out the screen was completely clogged with clutch material and this is what was causing the problem. I went through all of the same fixes that you tried: crank seal, oil pump o-ring, etc. It was this simple oversight that was the source of my grief.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×