Jump to content
Sign in to follow this  

CR85 Hanging Idle????

Recommended Posts

Got one that has me stumped. Running a 2003 CR85 that my kiddo uses for trail riding and desert riding. Kind of having fits getting it jetted right. To begin with, I have no idea about the history of this bike, but it has all kinds of aftermarket parts done to it. VForce reeds, Ice Cube cylinder head, FMF pipe, who knows about any porting work or anything else. Bike runs crazy fast and kid loves it. We are about 2500 ft above sea level and usually 60-100 degrees when we go ride. It came to us running a 135 main, 52 pilot, 3rd clip.

I have changed the pilot to a 45. My son is not as fast as the previous rider obviously was. Since he keeps it running in the low and midrange so much, he started fouling plugs. I usually have to jet the pilot circuit down for him, he is not agressive enough to keep it cleaned out and will foul plugs if I don't keep the pilot circuit lean.

Anyway, here is the problem. When he is riding and comes to a stop, the bike idles really high for about 10-15 seconds, then settles down into a good idle. I can ride the bike and really wring it out, and it still does it. I have checked for intake leaks and there are none. None of my other 2 strokes have ever done this. Any ideas??

Share this post


Link to post
Share on other sites

Just maybe the flywheel side oil seal has seen better days! pop the cover and see if there are any signs of oil dampness there

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×